Wikipedia / April Fools' Day Request for Comments
Wikipedia / April Fools' Day Request for Comments
A Request for Comments (RFC), in the context of Internet governance, is a type of publication from the Internet Engineering Task Force (IETF) and the Internet Society (ISOC), usually describing methods, behaviors, research, or innovations applicable to the working of the Internet and Internet-connected systems.
Almost every April Fools' Day (1 April) since 1989, the Internet RFC Editor has published one or more humorous Request for Comments (RFC) documents, following the June 1973 RFC called ARPAWOCKY, a parody of Lewis Carroll's nonsense poem "Jabberwocky". The following list also includes humorousous RFCs published on other dates.
List of April Fools' Day RFCs
1978
1989
1990
1991
1992
1993
1994
1995
1996
1997
1998
Updated by RFC 7168 in 2014.
1999
Updates RFC 1149.
Obsoletes MCMXCIX.
2000
2001
2002
2003
2004
2005
RFC Draft: "IP over Burrito Carriers"
2006
An April 1 RFC was not published this year, but an announcement on the IETF list about the appointment of the Sesame Street character Bert as member of the IAB appears to have been the April Fools' Day 2006 stunt.
2007
2008
2009
2010
2011
2012
2013
2014
2015
2016
An April 1 RFC was not published this year.
2017
2018
2019
2020
2021
2022
2023
2024
2025
2026
Other humorous RFCs
Submission of April Fools' Day RFCs
The RFC Editor accepts submission of properly formatted April Fools' Day RFCs from the general public, and considers them for publication in the same year if received at least two weeks prior to April 1. This practice of publishing April Fool's Day RFCs is specifically acknowledged in the instructions memo for RFC authors, with a tongue-in-cheek note saying: "Note that in past years the RFC Editor has sometimes published serious documents with April 1 dates. Readers who cannot distinguish satire by reading the text may have a future in marketing."
References
Further reading
RFC Editor home page – hosts individual RFCs
External links
– on RFC 3751 and April Fools' Day RFCs in general.